XGL/compiz en mi iBook

Desde que el disco duro de mi iBook murio y compre otro casi nuevo a Huasonic, he estado intentando dejar a mi querida portatil, con una distro Linux moderna, lo que para mi significa:

1. Gestion de paquetes Debian.
2. El ultimo kernel fichado como estable de la rama 2.6
3. UDEV / HAL
4. XORG 7.x
5. Soporte de direct rendering para mi ATI mobile M7 (Radeon 7500)
6. GNOME 2.15 (o mayor)
7. XGL / AIXGL, compiz (o alguna cosa con expose y cube effect)
8. MOL (Mac On Linux)
9. Pbbutons configurado como la gente (…capa, ehhh… ocho)
10. Mi Airport (no_Extreme) wep brainwashed capable


Debo confesar que me he vuelto adicto al sistema de gestion de paquetes de Debian, lo que de una u otra forma me ha cegado a probar alguna de las magnificas distros basadas en la gestion de paquetes de Red Hat.


Tambien debo reconocerme una fanatico empedernido del trabajo de la gente de GNOME (de hecho, intento hacerme parte del proyecto, lo mas que puedo), y de la forma “vivaracha” que los Ximian Boys han manejado el negocio.

Sin embargo debido a la inexistencia de escritos, pruebas, o cualquier clase de documento que acredite que alguna distro Debian PPC tiene soporte para
XGL/Compiz… o de un driver decente para la ATI de mi PPC (el propietario es solo para x86) he tenido que buscar alternativas en otros rumbos.

En ese camino, dentro de las distros RPM’s Based, mi eleccion natural resulto ser el Novell Linux Desktop, sin embargo, no tiene version para PPC (n-10 para Novell). En vista de las circunstancias, me decidi por la version de la comunidad, OpenSUSE (like Fedora Core).

Viniendo del mundo Debian, se que existen 3 estadios de una distribucion:

-Stable
-Unstable
-Experimental

La verdad, en mi vida jamas e usado la version stable de Debian. Generalmente uso la unstable, y cuando tengo tiempo libre, paso alguna maquina a Experimental… solo para ver cuando peta. 😀

Al enfrentarme al listado de downloads de OpenSUSE, solo me enfrento a 2 opciones:
10.1 y 10.2, y era que no, a pesar de los warnings en la lista (…mucho mas dulces que los que acompañan a la Debian Experimental), me decidi por la ultima version… pensando que la version Bleeding estaba por ahi en algun CVS/SVN solo para los iluminados Ximian’s 😛

La cosa es que instale la 10.2, y anda mas o menos mal.

1) El yaboot no reconocio automagicamente mi particion con OS X.
2) No habilito XGL por defecto como la “publicidad” anuncia.
3) Mi ATI andaba ultra lenta, sin aceleracion ni soporte 3D.

Asi que ahora debo bajarme otros 5 CDs con la 10.1, a ver si hace lo que yo necesito que haga.

Y no, no tengo mucho tiempo para dedicarle a la configuracion de mi laptop, necesito algo que trabaje como yo quiero, y rapido. Ya invierto demasiado tiempo con los otros unix que administro.

Esta semana voy a descargar la OpenSuse 10.1 y vere si puedo ser un real aporte.

Y no me digan que soy flojo por no querer configurarla. SI se que lo soy, solo que ahora realmente no tengo tiempo.

Quiero esto:

Y con un demonio que /SI/ lo voy a lograr.

Leave a Reply

Your email address will not be published. Required fields are marked *